Installation

RubyGems

Install terraspace via RubyGems.

gem install terraspace

Ruby 2.7 and above is recommended.

Terraform

Terraspace calls the terraform CLI. You will need terraform installed. Refer to the Terraform installation instructions to install terraform for your system. Terraform Terraform v0.12 and above is recommended.

Check Setup

You can use this command to check your setup:

terraspace check_setup

Linux Support Only

Terraspace currently only works on macosx and linux. For windows users, consider using the Cloud9 IDE, which runs in a browser and uses linux.

Cloud Provider CLI

Install the corresponding cloud provider CLI tool that you are using. Example:

Cloud Provider Credentials

If you need to set up the Cloud Provider credentials, here are the docs from the Getting Started Guides: